Quantcast
Channel: FromDual GmbH
Browsing index pages (402 articles)

Percona releases Galera Cluster Version 9.7

Finally, some good news again!What has happened so farAfter MariaDB Corp. acquired Codership OY—and with it, Galera Cluster for MySQL—in May 2025 [ 1 ], then announced the discontinuation of support...

View Article


MariaDB/MySQL Environment MyEnv 3.0.1 has been released

FromDual has the pleasure to announce the release of the new version 3.0.1 of its popular MariaDB, MySQL and PostgreSQL multi-instance environment MyEnv.The new MyEnv can be downloaded here. How to...

View Article


Recovering PostgreSQL Data When Blocks Are Corrupted

As part of our work on “PostgreSQL for Dolphins and Sea Lions,” I also enjoy reading the PostgreSQL mailing lists to see what kinds of problems come up and how they’re solved.One email in particular...

View Article

Making the PostgreSQL Documentation Even Better

While working on our project “PostgreSQL for Dolphins and Sea Lions,” I pored over the PostgreSQL documentation on replication.Since I’m not quite up to speed on this topic yet, I like to look up...

View Article

Artificially Delayed Replication with PostgreSQL

While working on our project titled “PostgreSQL for Dolphins and Sea Lions,” I pored over the PostgreSQL documentation on replication. What struck me was that PostgreSQL does NOT support artificially...

View Article


Someone is deleting my shared memory segments!

When we work with PostgreSQL under our myEnv, we regularly get shared memory segment errors. Example:psql: error: connection to server on socket "/tmp/.s.PGSQL.5433" failed: FATAL: could not open...

View Article

Backups Using the MySQL Clone Operation

We recently tested the PostgreSQL backup tool pg_basebackup and were very impressed with its remote backup functionality, which allows for both physical local and physical remote backups.This led us to...

View Article

PostgreSQL Point-in-Time Recovery with Oops-Queries

While working on the topic “PostgreSQL for Dolphins and Sea Lions,” I discovered that in the PostgreSQL universe, the topic of point-in-time recovery tends to be sidestepped when it comes to specific...

View Article


PostgreSQL Point-in-Time Recovery with Oops-Queries

While working on the topic “PostgreSQL for Dolphins and Sea Lions,” I discovered that in the PostgreSQL universe, the topic of point-in-time recovery tends to be sidestepped when it comes to specific...

View Article


Database Index Optimizer

Recently, a client asked me if the “time-consuming” task of checking indexes could be left to an index optimizer. Of course it can…What exactly do we want to check?Tables without a Primary KeyDuplicate...

View Article

MariaDB shortens maintenance period from 5 to 3 years

Somehow this news slipped past me: MariaDB has shortened the support period for the long-term releases of the MariaDB Community Server from 5 to 3 years. OK, I guess that’s not really surprising — I’ve...

View Article

MariaDB/MySQL Environment MyEnv 3.0.0 has been released

FromDual has the pleasure to announce the release of the new version 3.0.0 of its popular MariaDB, MySQL and PostgreSQL multi-instance environment MyEnv.The new MyEnv can be downloaded here. How to...

View Article

FromDual Performance Monitor 2.2.1 has been released

FromDual has the pleasure to announce the release of the new version 2.2.1 of its popular Database Performance Monitor for MariaDB, Galera Cluster, MySQL and PostgreSQL fpmmm.The FromDual Performance...

View Article


What is the quickest way to load data into the database?

We had some really exciting problems to solve for the last customer! Especially because the database wasn’t exactly small.Here are some key data: CPU: 2 sockets x 24 cores x 2 threads = 96 vCores, 756...

View Article

MariaDB has broken the concept of dynamically configurable buffer pools!

Problem descriptionMySQL introduced the dynamically configurable InnoDB buffer pool with 5.7.5 in September 2014 (here and here):The innodb_buffer_pool_size configuration option can be set dynamically...

View Article


How much space does NULL need?

The last time I consulted a customer, he came up to me beaming with joy and said that he had taken my advice and changed all the primary key columns from BIGINT (8 bytes) to INT (4 bytes) and that had...

View Article

Someone is deleting my shared memory segments!

When we work with PostgreSQL under our myEnv, we regularly get shared memory segment errors. Example:psql: error: connection to server on socket "/tmp/.s.PGSQL.5433" failed: FATAL: could not open...

View Article


FromDual Backup and Recovery Manager

Coming soon…Have also a look at the Backup and Recovery Manager Documentation.

View Article

Load CSV files into the database

Recently, I wanted to display the places of residence of the members of my club on a map for a personal gimmick (IGOC members). I knew the addresses of the club members. But not the coordinates of...

View Article

Attribute promotion and demotion in the MariaDB Galera Cluster

In MariaDB master/slave replication there is a feature called attribute promotion/demotion.Simply put, it is about how the slave behaves or should behave if the master and slave have different column...

View Article
Browsing index pages (402 articles)


Latest Images